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1 Product overview
Axcient DirectRestore (ADR) is a granular data extraction software for offline SQL databases and Microsoft
Exchange Server mailbox stores and Outlook files. The utility provides direct access to unmounted database
tables and mail store contents, displaying file structure and its contents with selective export functionality. With
a search query tool, users are able to export specific queries rather than large tables or files.
For SQL databases, recovered items can be saved as SQL scripts or exported directly to a live SQL server.
For Microsoft Exchange servers, files can be saved as Personal Storage File (.pst) files, to be opened with
Microsoft Outlook or other compatible email clients, or exported directly into live Exchange Server mailboxes.
The utility makes no changes to the store, preserving it in original unmodified state.
Main features of Axcient DirectRestore:
SQL Database
·Recovers entire tables, objects and object groups
·Recovers data obtained by specific search queries
·Recovers keys, scripts, functions, triggers and procedures
·Recovers default settings, user types and views 
·Saves single or multiple points of data as SQL scripts or exports to live SQL database

Microsoft Exchange Server
·Recovers mailboxes, folders, messages and file attachments
·Recovers contents of Public Folder mailboxes
·Recovers email addresses from Active Directory storage
·Recovers notes, contacts, tasks and appointments
·Recovers creation dates for all objects
·Saves selected items to PST files or exports to live Exchange Server mailbox(es)
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1.1 Supported Exchange database versions
Axcient DirectRestore supports the following mail store versions:

· Exchange 2019 CU14;

· Exchange 2019 CU13;

· Exchange 2019 CU12;

· Exchange 2019 CU11;

· Exchange 2019 CU10;

· Exchange 2019 CU9;

· Exchange 2019 CU8;

· Exchange 2019 CU7;

· Exchange 2019 CU6;

· Exchange 2019 CU5;

· Exchange 2019 CU4;

· Exchange 2019 CU3;

· Exchange 2019 CU2;

· Exchange 2019 CU1;

· Exchange 2019 RTM;

· Exchange 2016 CU23;

· Exchange 2016 CU22;

· Exchange 2016 CU21;

· Exchange 2016 CU20;

· Exchange 2016 CU19;

· Exchange 2016 CU18;

· Exchange 2016 CU17;

· Exchange 2016 CU16;

· Exchange 2016 CU15;

· Exchange 2016 CU14;

· Exchange 2016 CU13;

· Exchange 2016 CU12;

· Exchange 2016 CU11;

· Exchange 2016 CU10;

· Exchange 2016 CU9;

· Exchange 2016 CU8;

· Exchange 2016 CU7;

· Exchange 2016 CU6;

· Exchange 2016 CU5;

· Exchange 2016 CU4;

· Exchange 2016 CU3;

· Exchange 2016 CU2;

· Exchange 2016 CU1;
· Exchange 2016 RTM;
· Exchange 2013 CU23;
· Exchange 2013 CU22;
· Exchange 2013 CU21;
· Exchange 2013 CU20;
· Exchange 2013 CU19;
· Exchange 2013 CU18;
· Exchange 2013 CU17;
· Exchange 2013 CU16;
· Exchange 2013 CU15;
· Exchange 2013 CU14;
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· Exchange 2013 CU13;
· Exchange 2013 CU12;
· Exchange 2013 CU11;
· Exchange 2013 CU10;
· Exchange 2013 CU9;
· Exchange 2013 CU8;
· Exchange 2013 CU7;
· Exchange 2013 CU6;
· Exchange 2013 CU5;
· Exchange 2013 SP1;
· Exchange 2013 CU3;
· Exchange 2013 CU2;
· Exchange 2013 CU1;
· Exchange 2013 RTM;
· Exchange 2010 SP3;

· Exchange 2010 SP2;

· Exchange 2010 SP1;

· Exchange 2010 RTM;

· Exchange 2007 SP3;

· Exchange 2007 SP2;

· Exchange 2007 SP1;

· Exchange 2007 RTM.

1.2 Supported Outlook versions
Axcient DirectRestore supports the following versions of Outlook
PST files: 2019, 2016, 2013, 2010, 2007, 2003, XP, 2000, 98 and 97.
OST files: 2010, 2007, 2003, XP, 2000, 98 and 97.

1.3 Supported SQL Server database versions
Axcient DirectRestore supports the following versions of MDF/BAK files (including Express edition):
2022 (RTM - CU17), 2019 (RTM - CU30), 2017 (RTM - CU31), 2016 (RTM - SP3), 2014, 2012, 2008R2, 2008
and 2005
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1.4 System requirements
Basic system requirements:

· Operating systems: Windows 11, Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server
2025, Windows Server 2022, Windows Server 2019, Windows Server 2016, Windows Server 2012 R2,
Windows Server 2012, Windows Server 2008 R2 SP1, Windows Server 2008 SP2;

· Software: .NET Framework 4.6.2 or higher;

· RAM: 1024MB, depends on store size and OS version;

· Hard Disk: minimum 250MB of free space required for installation;

· Display: 800 x 600 or higher resolution, 256 colors.
Additionally, Axcient DirectRestore may require free space on disk 1.5x the size of mail store being
processed. For example, for 300MB store, 450MB free space should be available.

1.4.1 Live Exchange Server export requirements
Exchange Server
Exchange Server 2019, 2016, 2013, 2010 or 2007
Exchange Web Services enabled on Exchange Server
Network
Port 443 open on the network. The EWS messages are transported via SOAP-based API, which is essentially
sending XML data using https protocol.
Restore client
ADR installed. Access to Exchange server(s) over network.

1.4.2 Live SQL Server export requirements
SQL Server
SQL Server 2022, 2019, 2017, 2016, 2014, 2012, 2008R2, 2008 or 2005
SQL Server Browser running on SQL Server 
Network
To establish connection to live SQL Server, remote network access must be allowed on the server and TCP/IP
protocol must be enabled in SQL Server Configuration Manager.
Restore client
ADR installed. Access to SQL Server(s) over network.
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1.5 Limitations
Current version of the product has the following limitations:

· While processing dirty shutdown databases storages may be restored not to the topical condition.

· Messages in the Outbox folder are not restored if they haven't been synchronized with the server.

· Simultaneous recoveries are not supported.

· Simultaneous running of more than one instance of the product is not supported.

· Encrypted emails are not restored.

· Messages with size over 64MB are not supported.

· Windows Vista, XP, 2000, 98, ME, 95 and 2003 Server are not supported.

· Recovery of delivery receipts and non delivery reports is not supported.

· Tool doesn't support usage in "Run as different user" mode.

· OST files, created in Outlook 2013, 2016, 2019 are not supported.

· Password-protected PST files are not restored in command-line interface.

· Command-line interface is not supported for MDF and BAK files.

· Compressed BAK files from SQL Server 2014 and newer are not currently supported.

· System MDF and BAK files are not currently supported.

· Encrypted SQL databases are not currently supported.

· Calculated fields and fields of type [sql_variant] in indexes cannot be used in SQL database search.

· Sparse columns in SQL database are not supported.

· Filestream data type and Filetables in SQL databases are not currently supported.

· Searching by 'real' data type may return not full results.

· Approved status of Calendar Events is not supported.

· Links to the Exchange Global Address List are not supported.

· Exchange Server Databases: Preview items with 4-byte Unicode characters may be not full in product
started on Win7 and WS2008 OS. It is not affect on quality of restoring into PST or into live server.

· Exchange Server Databases: Search input field may work incorrectly with 4-byte Unicode characters. It
does not affect on results of search.

· Exchange Server Databases: Distribution lists linked to contacts are not supported.

· MS SQL Server: schemas with name containing a dot (".") - for example, "[custom.schema]" - can not
be restored.

· MS SQL Server 2017: restore of graph tables is not supported.

· MS SQL Server: for "sql_variant" datatype basetypes are not restored correctly (values are restored
with "nvarchar" basetype).

· MS SQL Server: secondary data files are not currently supported.

· MS SQL Server: decimal values close to maximal/minimal can not be restored to live SQL server through
injection.

· MS SQL Server: history tables of system-versioned temporal tables are not supported.
Injection limitations for Exchange Server 

· To restore a mailbox, an empty mailbox must be created in advance using the standard Exchange
Server administration tools or can be created from ADR. In existing mailboxes folders and individual
messages can be created without any additional administrative actions.

· It is possible to rename/delete folders in the attached mailbox only within one program session.

· Injection will not be supported for Exchange Server 2003 and earlier versions. These versions do not
support EWS.

· Archived mailboxes (and items from such mailboxes) are not exported to live Exchange Server.

· Photos of contacts are not exported to original live mailbox in Exchange Server 2007.

· Emails with embedded images and other OLE objects are displayed with an attachments icon after
exporting into live Exchange Server.

· Creation time and modified time are not restored.

· Exporting data into live public folder is not supported.

· Exporting data from PST/OST files into original mailbox is impossible.
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· Contact groups and meeting requests cannot be exported into live Exchange Server 2007 instances.
Use export through PST for these item types. 

· Missing sent date is exported as current date/time into live Exchange Server.

· It is impossible to use the connection to the archive mailboxes, as they can not be found in the Active
Directory.

· For IPM.Task class items existing "Date Completed" value is exported into live Exchange Server as
current date/time.

· For IPM.Task class items "Update List" field is not restored after injection. 
Limitations for search in attachments content (available for EDB/PST/OST files)
Search in attachments does not work for:

· Text contained in embedded OLE objects, WordArt and smart objects, charts etc. Documents metadata
(author, comments, tags etc.). 

· Marker symbols in lists (numbered or bulleted).

· Text in header/footer.

· XLS/XLSX: number values, formulas, cell comments.

· PPT: tables content.
Mailbox creation limitations:

· Creating new mailbox is not supported on Exchange Server 2007 and earlier versions.

· Prior to creating new mailbox on Exchange Server it must be properly configured.

· The machine with Exchange Server must have Exchange PowerShell installed.

· Exchange Server connection must be performed using credentials of the user who has permission to
create mailboxes (e.g. Administrator).

Tip
Note that the utility is best used for granular item extraction. The user interface of the program is designed
for ease of locating, selecting and exporting specific messages, folders or mailboxes. Entire databases can
be exported as well, but the restore time will significantly increase over a slow connection. For bulk
operations that involve exporting more than one mailbox it is typically better to work with a local copy of the
database.
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1.6 Boundaries for optimal recovery and search
Usage of Axcient DirectRestore is optimal for files that do not exceed:
EDB:

· EDB size: 2TB

· Mailbox size: 100GB

· Number of messages in the EDB file: 2,000,000

· Number of mailboxes in the EDB file: 2,000

· Number of messages in one mailbox: 100,000
PST/OST:

· PST/OST size: 100GB

· Number of messages in the PST/OST file: 200,000

· Number of folders in the PST/OST file: 1,000

· Number of messages in one folder: 100,000
MDF/BAK:

· MDF/BAK size: 1TB

· Number of tables in the MDF/BAK file: 1,000

· Number of rows in one table: 10,000,000
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1.7 Customer support
For customer support, please contact Axcient using one of the methods listed below.

Online: https://partner.axcient.com/

Email: support@axcient.com

Tip
When contacting customer support with a technical issue, please have ready the program's log files and
the store you are having difficulty with.
Complete the following steps to gather logs:
1. Clear the existing contents of the log folder: File -> Delete saved temp files and logs
2. Enable debug logging: Options -> Debug logging

Debug logs are extended application-related logs, providing these to customer support team can
significantly speed up our analysis of any issues.

3. After debug logging has been enabled, you must restart Axcient DirectRestore and then reproduce the
issue.

4. After you have finished collecting extended debug logs, restart Axcient DirectRestore and disable
debug logging.

5. To get log files, click File menu and choose Open log folder. Zip the contents of the folder and attach
the resulting archive to your support request.
If the log archive and/or mail store exceeds 10MB, it may be impossible to send them as an email
attachment. In that case, upload instructions will be provided to you upon request.

https://partner.axcient.com/
mailto:support@axcient.com
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2 Installation
This chapter describes the steps required to install Axcient DirectRestore.
Depending on your preferences, it is possible to install the product in default or advanced mode.

Default mode
Default mode provides simple setup that requires just a few mouse clicks to complete. For the sake of
simplicity, it does not offer any customization capabilities and uses the following default settings:

· Axcient DirectRestore will be installed in a per-user folder and be available just for your user account.
You do not need local administrator privileges in this case.

· The default installation location is "C:\Program Files (x86)\Axcient\DirectRestore\"

· A shortcut for this program will be created on the desktop automatically.
Step by step instructions:
1. Double-click on the setup file to start the installation process.
2. The Software License Agreement appears. Read it and accept the terms in the License Agreement.
3. Click Install to start setup.

4. The installation will start. When finished, you will have an option to launch the installed product.
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Advanced mode
Advanced setup mode allows changing default installation options.
Step by step instructions:
1. Double-click on the setup file to start the installation.
2. The Software License Agreement appears. Read it and accept the terms in the License Agreement.
3. Click Advanced to change installation options described above.

4. Click Next to install the product to the default folder or Change... to choose another folder. To add an icon
shortcut to the desktop for quick start of the program, check Create a shortcut for this program on the
desktop. Click Next.

5. Click Install to begin the installation. Click Back to change any of your installation settings. Click Cancel to
exit the setup wizard.

6. After the installation finishes you can choose to Launch Axcient DirectRestore when setup exits to start
the program automatically by clicking the appropriate checkbox. Click the Finish button to exit the setup
wizard.
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2.1 Product activation
When starting Axcient DirectRestore for the first time, you will be prompted to activate the product using one
of two methods:

Activation method #1: Use an x360Portal account
This activation method is suitable for most users. Choose this option if you have an account on x360Portal
(with a license for x360Recover) or an account on x360Recover Manager.

Activation method #2: Use an Axcient-supplied license key
This is an alternative activation approach. Choose this option if you don't have an account on x360Portal or
x360Recover Manager but you do have a license key (provided by Axcient.)

Note
If you make a mistake during the selection process (and need to re-select a different activation method),
you will have the option of clicking a Back to method selection button on the top right of the individual
method screens.
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Activation method #1: Use an x360Portal account
For this method, you must be connected to the internet.
DirectRestore opens x360Recover Manager (RMC) using an embedded browser to log in.

Note
If you don’t immediately see the login screen, allow a few moments for the web page to load.

Note
The license obtained through x360Portal / x360Recover Manager is valid for 30 days. After 30 days, you
must repeat the activation steps.

1. Enter either the username or the email. (Only one is required for this step.) Click Continue.

2. Enter the password. Click Submit to continue.
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3. If multi-factor authentication (MFA) is enabled, enter the MFA code. Click Verify to continue.

4. When the login is successful, your license activation will be completed. DirectRestore will then display a
confirmation message. The license manager will close after you click OK.
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Activation method #2: Use an Axcient license key
You must use the license key provided by Axcient.

Note
If you don't have a license key, please click Support to contact us and request it.

1. Enter the license key, your name and the company name. Click Next to continue.

2. If the license key is valid, your license will be activated and a confirmation message will be displayed. Click
Finish to complete the activation.

Tip
When getting an error message, first of all check if the license key has been entered correctly. It's best to
copy and paste the key to avoid typos.
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2.2 Updating the product
In order to update the product automatically as soon as a new version is released, use auto-update, available
in the Options menu.

If these options are enabled, user will be notified about the new version by the following dialog and update
process will start in 15 seconds:

In case if the point Update automatically is not checked, user should manually click the Download and
install button.
To disable this option remove the check marks Check for updates on startup and Update automatically. 
In this case you will not get any notifications, when a new version becomes available for downloading. Use
Check for updates in the Updates menu to verify if any updated version is ready to be used.
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3 Opening a file
To directly open a file for browsing and export, launch Axcient DirectRestore and click file open button on the
taskbar or select File|Open from the menu. On first launch, the file open dialog will be shown automatically.
Select the store you will be working with and click Open.

By default, a progress window will accompany opening the selected file. The window displays overall progress
and information about the number of items and objects in the file (1). The window can be disabled by
unchecking the Show the dialog next time check box (2) or from the Options menu. The progress window
will be automatically closed in 3 seconds after database opening (3).

Current operation can be cancelled right on the progress dialog, by clicking an appropriate link.
After loading the file is complete, it will be available for browsing and export. The opened store will also
become the default store and will be automatically reopened next time you launch the utility.
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Opened database can be reloaded with database log files. Go to the File menu and select Reload database
using transaction logs. 

Note
If you closed the progress window, it can easily be shown again by clicking on the progress bar on the
status panel.

Note
Best practice is to perform Exchange and SQL recovery operations on the original server, by a user that
has admin access to the affected services. It’s also possible in most cases to perform such operations
using Recovery Center from a workstation or other system, so long as the device is part of the domain and
the user has the appropriate access permissions to the data.
Otherwise, if the user tries to access a backup file from a machine with no accounts matching access
control list (ACL) of that file and tries to open it, they will see the error “You don’t have permission to open
this file”.
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3.1 Finding a file
In case when the location of the file is unknown, it is recommended to scan existing drives to find the data. 
Axcient DirectRestore scans local drives, both mounted and unmounted, as well as network drives and
searches for PST/OST, MDF/BAK and EDB files.
To start a new search click Search for files to open in the File menu.

The following form appears, displaying the list of mounted disks:

To use unmounted disks (NTFS and FAT32 file systems are supported) for search, check Include
unmounted volumes. All unmounted volumes will appear in the list of disks.
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Note
Only NTFS and FAT32 file systems of unmounted drives are supported.

Select a location to search in.

List of found files will be displayed. Double-click a file to open it. 
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Note
To scan unmounted disks, the user, running the program, must have administrative rights.
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4 Axcient DirectRestore. SQL Server

4.1 Finding and browsing data
In general, Axcient DirectRestore provides two modes of processing file data: browsing the file tree and
search. Using these, it is possible to efficiently form a set of objects for subsequent export, including the
necessary ones and excluding ones to be skipped.

A newly opened database is shown in the Browse mode.

4.1.1 Browsing database tree
Browse mode shows database in a tree-like structure and allows browsing folders and previewing individual
objects.
This mode is best for navigating to a specific object, when it is precisely known what data needs to be
extracted.
For example, a user may ask to restore some specific table. Expand the folder 'Tables' in the tree and select
the table. Available rows will be listed to the right of the tree. Please note that product will not try to load all
rows in table. Instead of that rows will be loaded by portions each time you navigate to the end of list.
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In case if SQL script of a table is necessary, just right-click on the table in the database tree and select 'Show
SQL script' in the context menu. 

Any particular row can also be scripted via context menu. By right click on the row, SQL script can be either
shown or at once copied to clipboard.
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Rows filtering provides the ability to easily find specific values in tables. To enable filtering, just start typing
necessary data, when focus is on the list or press Ctrl+F keys. Please note that rows filtering works only for
rows that was already loaded in current view.
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4.1.2 Using search
Axcient DirectRestore provides several ways to search for data:

· Standard search

· Search for related data

· SQL Query search
To access the Search tool, select a table where the search will be performed and click on the Search Bar (1)
located at the top of the window.

Search results will be displayed on separate tabs with the ability to select query results and export them either
into Live SQL Server or in the form of SQL script files which can be executed on server manually.
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Standard search mode
To access Standard search click on the Search Bar and select 'Standard search' tab in the displayed window.

There are three sets of parameters to customize for this search:
Fields to search (1)
This options defines the set of fields which will be used to perform search. The user can choose to search in
all indexed fields, all fields, custom selection from indexed fields or custom selection from all fields.
Multiple field match type (2)
In case more than one field is selected for search the user can choose which logical operator will be used to
combine these fields.

· OR - search results will include records which have at least one field that matches search parameters.

· AND - search results will include records which have matching values in all fields which were selected for
search.

Fields (3)

If Custom (indexed only) or Custom was selected in Fields to search the user will be able to choose fields

which will be used for search. To select a field simply click on the field name, the field will then become
selected and the user will be able to choose which comparison operator to use and to enter the value to
search for.
There are also two ways to fill search fields with values from selected tow, which helps to avoid entering long
string manually:

· Right-click on a row and select Search for similar data from context menu. This fill set the field selection to

Custom and fill search from with values from selected row.

OR

· Select a row, then select Standard search tab and click Prefill button.
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Search for related data
Search for related data can be used to search for rows which relate to the selected row - that are rows which
have fields from the selected table as foreign keys.

Related data search can be accessed either by right-clicking on a row and selecting Search for data related

to... from context menu or by selecting Related data tab in search window.

The application will analyze the selected table and automatically detect which fields are used in other tables as
foreign keys (1). It will also provide a list of tables which relate to the selected table (2).
The user will then be able to enter field values which will be used when searching for related data and select
from a list of tables where to perform search.
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SQL Query mode
SQL Query search mode provides the ability to write complex search queries using SQL-like query language
to narrow search results as much as possible.

SQL query mode can be accessed by clicking on Search Bar and selecting SQL tab.

The user is presented with a text field (1) which is used to enter search query. The beginning of the query is
given and the user has to fill in the remaining part of WHERE clause.
The query may include field names, comparison operators, field values, logical operators and brackets. The
text field makes it easier for entering search query by providing auto-complete feature, which automatically
suggests possible query elements. The auto-complete window will appear automatically when first letters of
query are typed, it can also be accessed by pressing Ctrl+Space. To select an item (field name, logical or
comparison operator) from the list please press Tab or Enter.

Query examples are given at the bottom of the SQL tab (2).
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4.2 Exporting items
Axcient DirectRestore allow a user to export the whole database or just particularly objects (tables, views,
functions, etc.) into live SQL Server and to SQL scripts, that can be used for manual import to a live server.

4.2.1 Restore to live SQL Server
Axcient DirectRestore includes the injection capability for items (tables, views, functions, etc.) from offline
database and BAK file to live SQL database.
The following options are presented:

· Authentication

· Connection to a database using valid credentials. To provide the connection, host (domain name or IP),
user logon name and password are required. It is also possible to connect through current Windows
credentials.

· Connecting to several tables on different servers simultaneously.

· Browsing folder hierarchy of a connected database, browsing folder contents and viewing objects and rows.

· To provide injection, running the application as administrator or using a machine from AD domain, in which
there is SQL Server with destination database, is not required.

Connection to SQL Server
The mode, that allows connections to live server, is enabled by default. The Destination tab, as well as the
ability to connect to live server, can be hidden from the Options menu.

To establish a new connection, use the button Connect to live server (1), next to the Search field or go to
File->New connection->Attach to live SQL Server database (2).
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To access the server, enter the domain name or the IP address, or just click on the arrow (1) to get the drop-
down list of automatically detected servers and provide valid credentials.

List of available databases will be shown after clicking the Refresh button (1) or the arrow near the Database
name field (2), if entered credentials are correct.
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Injection workflow
Once data has been selected, click the Export button and select an Export option.

Axcient DirectRestore presents several injection modes for specified data:

· Export to original object - The source object will be restored to the object listed under Destination Object.

Important: When restoring an object (database or table) into an empty object on the live server, the user
must first export its schema (see ‘Schema only’) and only then export its data.

· Export to new Object - The user may edit the Destination Object for any source object, and the Axcient

DirectRestore application will create a new destination object to restore to.

· Schema only - Export only the schema of the source objects. The destination object can be edited and the
schema(s) will be restored to the new destination object.

· Unselect successfully exported objects - This will unselect the data objects that were selected for export
once they have been successfully exported to the live server. This will allow the user to more easily identify
which objects encountered errors and were not exported.

Note
Axcient DirectRestore does not check for duplicates in the destination table and cannot guarantee that they
will not appear after exporting data into existing tables on a live server, especially if the user performs
consecutive exports of the same table. To prevent data duplication, the administrator should set up
constraints in the destination table on the live SQL Server.
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4.2.2 Restore to SQL scripts
To save objects marked for export, click the Export selected objects into SQL scripts button on the toolbar
or select the point in the File menu.

To start exporting process, select destination folder or create a new one and click OK.

Required time depends on how many objects are selected for export. By default, a progress window appears
after the export starts. The window shows the number of saved objects and rows (1). You can disable the
progress window directly in the window or go to the Options menu and select Show progress dialog.
The export can be cancelled by clicking an appropriate link in the progress dialog window (2) or by clicking
the Cancel export button on the taskbar (3).
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Tip
If you closed the progress window, it can be shown again by clicking on the progress bar on the status
panel.

Restoring exported scripts into SQL Server
SQL scripts exported from the offline database can be easily imported into live SQL Server manually
For this purpose a special bat-file, commit.bat, is generated while extracting data. It is stored in the folder with
restored scripts.
Usage for trust connection:
commit.bat server_name db_name

Usage for mistrust connection:
commit.bat server_name db_name user_name password
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5 Axcient DirectRestore. Exchange Server

5.1 Special features
Usage of Axcient DirectRestore can be more comfortable for a user due to additional Options menu, which
allows user to customize program work.
Detailed information about every option is described in this help section.

Note
PST encoding and Show deleted items options are not available for PST/OST files.



Axcient DirectRestore

Page 38Version 22.2.0
Copyright ©2025 Axcient All Rights Reserved.

5.1.1 PST encoding
Exporting mail store data into PST allows to select a PST format that suits your version of Microsoft Outlook.
Outlook 2019, 2016, 2013, 2010, 2007, 2003 process both Unicode and ANSI PST files, but as for older
versions such as Outlook 2002 and earlier, they will not be able to open Unicode-formatted PST files. Previous
versions of Outlook were using only ANSI format. The main reason for this change was to allow for
international character support and to extend the maximum size of PST files beyond the 2GB limit of the ANSI
formatted PST files.
In Axcient DirectRestore there are two ways to select suitable encoding for output PST.
Output PST encoding can be changed while selecting a destination folder for restored PST files.

Alternatively, encoding for the output file can be changed in the Options menu at any time the program runs.
Selected value will be saved and used on the next program launch.
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5.1.2 Incomplete messages
Incomplete messages, such as messages with missing properties, bodies, are hidden by default. This option
can be changed in the Options menu.

Note
After changing the way of displaying incomplete items, the database will be reopened
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5.1.3 Showing system folders
System folders are hidden by default. This option can be changed in the Options menu.

Note
After changing the way of displaying system folders, the database will be reopened.
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5.1.4 Showing deleted items
Axcient DirectRestore provides an ability to process deleted items and folders.
This special feature can be enabled via the Options menu. There are three available display modes:

· non-deleted items - displays actual items in folders;

· show only deleted items - displays items/folders deleted from a mailbox hierarchy, but not physically ;

· show both deleted and non-deleted items - displays both actual items in folders and items/folders deleted
from a mailbox hierarchy.

Note that after selecting any way of processing deleted items, the database will be reopened.
Items, deleted from Exchange Server 2010 and 2013 databases, are stored in the folder Deletions and have
an appropriate type.

As for items deleted from Exchange Server 2007 databases, they are stored in the their original folders but
can be easily recognized by an appropriate status.

Note
Items, stored in the folder Deletions, cannot be recovered to live Exchange Server database. It is
recommended to restore items from the Deletion folder to PST and then import to live Exchange Server.
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5.1.5 Display time
There are two dates display formats available for users, local time and GMT.
To switch dates display format between local computer time and GMT, use the Options menu.

If you switch display time, a warning, that the file will be reloaded, appears.

A message in GMT format looks the following way:
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5.1.6 Showing notification panel
Every program action is accompanied by an appropriate notification for user. Notification panel is disabled by
default, but can be easily enabled by checking Show notification panel in the Options menu.

After that user will see additional information about opening file, export results, search results, etc.
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5.2 Finding and selecting messages, folders and mailboxes
Axcient DirectRestore provides two mutually complementary modes of finding, previewing and selecting items:
browsing the mailbox tree and search. Using these, it is possible to efficiently form a set of items for
subsequent export, including the necessary ones and excluding ones to be skipped.
A newly opened database is shown in the Browse mode.

5.2.1 Browsing mail store tree
Browse mode shows mail store in a tree-like structure and allows browsing folders and previewing individual
items.
This mode is best for navigating to specific mailboxes, folders and messages when it is precisely known what
data needs to be extracted.
For example, a user may ask to restore a specific message from a known folder. Expand his or her mailbox in
the tree, select the folder, find and click the item. All available properties and information about the item will be
displayed in the Preview window to the right of the tree.
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There is a check box next to the message. Check it to mark the message for export.
Continue to mark other items, folders and mailboxes for export in a similar way.

Use filtering feature for better browsing the list of items in a folder.
Enable filtering by pressing Ctrl+F keys. A special panel will appear in the right part of the program window.



Axcient DirectRestore

Page 46Version 22.2.0
Copyright ©2025 Axcient All Rights Reserved.

Use search in preview feature for quick find text in item preview.
Enable search in preview by pressing Ctrl+D keys after opening preview of item. A special panel will appear
in the right part of the program window.

Tip
Each individual item, folder and mailbox has a check box next to it. Using these check boxes, it is possible
to select as many or as few items for export as necessary.
To export an entire

· mail store, mark the root check box with the mail store name.

· mailbox, mark the check box next to mailbox in the tree.

· folder, expand a mailbox and mark the check box next to the desired folder.
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5.2.2 Using search
The search in the main window provides the ability to search single or multiple mailboxes and perform actions
on the search results.
The best application of search mode is when the location and/or number of items to extract is not known
exactly. Using keyword search, it is possible to narrow down on specific messages, folders and mailboxes.
The quickest way to get search results is clicking on a particular mailbox, entering some keywords in the
Search field and clicking the button Start search.
Search results will be displayed on a separate tab.

If a user knows exactly in what mailbox or folder the data is located, using Search in mailbox option will
speed up the search.
Right-click on a folder/a mailbox will open a context menu.
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By clicking on this menu advanced mode of search dialog will be opened and Search in field will be filled with
the selected mailbox/folder.
Fill in necessary search parameters and start the search.
For more precise searches click on the Search field, drop-down list of all search fields will appear:

· Search in - specifies mailbox(es)\folder(s) to search in. Default: entire database. If you select one or more
Search in check boxes, but specify no additional search criteria, the utility will return all items from the
selected folder(s).

· Has words - search for mail store items that have words or phrases entered in the field.

· Doesn't have - search for items that do not have words or phrases entered in the field.

· Has attachments - search for items with attachments.

· From - search for keywords in the From: field.

· To - search for keywords in the To: field.

· Subject - search for keywords in subject.

· Date range - set specific date range if known. It is obligatory to set both the beginning and the end of the
desired time period.

The outcomes of a search can be:
1. The program was able to find items (1) that corresponds to specified search parameters (2). The user can

select separate items or mark search results for recovery.
Clicking an item in the search results tab will open the item preview. Selecting item(s) in search results will
make their recovery possible.
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‘Find whole word only’ is not enabled by default. This option can be changed in the search parameters. When
‘Find whole words only’ option is selected an exact match search will be performed.

Counters of found elements are automatically updated or can be updated manually by clicking on the Refresh
button. If any folder is selected and the program has found new elements in it, then the following value will be
shown: previous(value, when we selected the folder) value of a counter + count(in green) of newly found
elements, which will be updated in real-time.
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Words and phrases which match the search query are highlighted in the preview, which helps to easily
identify where the match was found.

2. The search didn't match any items. Review search parameters and run another search.
To delete temporary data, generated by Axcient DirectRestore, go to the File menu and click Delete saved
search indexes and logs.
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Note

Next search in the same folder/mailbox will be almost instant (only if saved search indexes and logs haven't
just been deleted).

Note
Search with empty query is not available.

Note
Asterisk ('*') is added to all words in search fields by default. This allows to find not only specified words
but also their word forms. Use ‘Find whole word only’ option or quotes (" ") to search for an exact phrase.
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Advanced search
Advanced search uses symbols and operators in queries. These operators allow you to find what you're
looking for quickly and accurately.
To use advanced search enter operators and their values into the Search field (1). 

Operators are listed below:

Operator Definition Example

from: Used to specify the sender. Example: from:alex
Meaning: messages from Alex.

to: Used to specify a recipient. Example: to:John
Meaning: all messages that were sent to
John (by any user).

subject: Search for words in the subject
line.

Example: subject:dinner
Meaning: messages that have the word
"dinner" in the subject.

OR Search for messages matching
term A or term B.
OR must be in all caps

Example: from:alex OR from:john
Meaning: messages from Alex or from
John.

AND or Space Search for messages matching
term A and term B.
AND must be in all caps.

Example: from:alex AND from:john
Meaning: messages from Alex and from
John.

-
(hyphen)

Used to exclude messages from
your search.

Example: dinner -movie
Meaning: messages that contain the word
"dinner" but do not contain the word
"movie".

has:attachment Search for messages with an
attachment.

Example: from:john has:attachment
Meaning: messages from John that have
an attachment.
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Operator Definition Example

att_name: Search for messages with
specified attachment name.

Example: to:jane att_name:photo.png
Meaning: messages to Jane that have an
attachment with specified attachment
name.

cc:
bcc:

Used to specify recipients in the
cc: or bcc: fields
Search on bcc: cannot retrieve
messages on which you were blind
carbon copied.

Example: cc:John
Meaning: messages that were cc-ed to
John.

" "
(quotes)

Used to search for an exact
phrase*
*capitalization isn't taken into
consideration.

Example: "i'm feeling lucky"
Meaning: messages containing the phrase
"i'm feeling lucky" or "I'm feeling lucky".

Example: subject:"dinner and a movie"
Meaning: messages containing the phrase
"dinner and a movie" in the subject.

( ) Used to group words
Used to specify terms that shouldn't
be excluded.

Example: from:alex (dinner OR movie)
Meaning: messages from Alex that contain
either the word "dinner" or the word
"movie".

Example: subject:(dinner movie)
Meaning: messages in which the subject
contains both the word "dinner" and the
word "movie".

create_time:[yyyymmdd
yyyymmdd]

Search for messages created
during a certain period of time.

Example: create_time:[20110416
20110516] 
Meaning: messages created between
April 16, 2011 and May 16, 2011.

after:
before:
older:
newer:

Search for messages sent or
received during a certain period of
time 
(using the date format yyyymmdd).

Example: after:20110416
before:20110516 
Meaning: messages sent between April
16, 2011 and May 16, 2011.

More precisely: messages sent after
12:00 AM (or 00:00) April 16, 2011 and
before May 16, 2011.

older_than:
newer_than:

Similar to older and newer, but
allows relative dates using d, m,
and y for day, month, and year.

Example: newer_than:2d
Meaning: finds messages sent within the
last two days.

size: Search for messages larger than
the specified size in bytes.
Abbreviations for numbers (B, K,
M) are allowed. Size limit is
2000MB.

Example: size:300
Meaning: messages larger than 300 bytes

Example: size:[300 2000]
Meaning: messages larger than 300 bytes
but smaller than 2000 bytes.

larger:
smaller:

Similar to size, allows abbreviations
for numbers (B, K, M). Size limit is

Example: larger:1M
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Operator Definition Example

2000MB. Meaning: All messages of at least 1MB in
size.

Example: larger:150K smaller:1M
Meaning: messages larger than 150KB
but smaller than 1MB.

+
(plus sign)

Match the search term exactly. Example: +movie
Meaning: minds messages containing
“movie” but not “movies” or “movei”.

Using wildcard characters
A wildcard character is a keyboard character such as an asterisk (*) or a question mark (?) that is used to
represent one or more characters when you are searching for files, folders, printers, computers, or people.
Wildcard characters are often used in place of one or more characters when you do not know what the real
character is or you do not want to type the entire name.

Wildcard character Definition Example

*
(asterisk)

Used to substitute for zero or more
characters.

Example: subject:d*g
Meaning: finds messages containing
words "doing", "dog", "debug", etc.

?
(question mark)

Used to substitute for a single
character in a name. 

Example: subject:d?g
Meaning: finds messages containing
words "dog", "dig", "dug", etc.

Note
Use checked 'Find whole word only' in case using question mark ("?") in the start of the word. 

Note
Other special characters are not used for search. Search query, containing special characters, may
return incorrect results.
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Search within attachments
Search within attachments is not enabled by default. This option can be changed in the Options menu.
This option allows to perform search in attachments’ content.

Note
After enabling this option the database will have to be reopened. Search process may take longer when
search within attachments is enabled.
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5.3 Exporting items
Axcient DirectRestore includes the injection capability for items (emails, calendars, contacts, etc.) from offline
database and PST/OST files to original live Exchange databases as well as granular data extraction to
Personal Storage File (.pst) files.

5.3.1 Restore to original live Exchange Server. Standard mode

Important Note
Standard export mode requires access to Active Directory to establish connection to Exchange Server.
The program requests users list from Active Directory and checks if IDs of offline and live user mailboxes
match. That's why the user, logged in, must be a domain user.

After startup, opening an EDB file and checking items the main window of the application looks as follows:

Clicking the injection button will bring up the following dialog:
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Domain name of the machine with Exchange Server will be automatically detected if current machine is in the
same domain with Exchange Server. Otherwise, the host will not be detected and has to be entered manually.
By default, Axcient DirectRestore uses current user to establish the connection. If current user doesn't have
rights to impersonate selected for export user, an appropriate error will appear in details.
In case of error it is recommended to use the Advanced button and configure the connection settings.

There are two ways to connect to selected mailbox: 
1. Use credentials of selected mailbox. 
2. Specify the user that has impersonation rights. 
To use credential of selected mailbox, enter host name of machine with Client Access Role, unmark Use
current Windows credentials enter user name and password and press Connect. 
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To use Exchange impersonation to establish the connection, enter host name of machine with Client Access
role, unmark Use current Windows credentials, enter credentials of the user with impersonation rights and
press Connect. In the example below Brian has impersonation rights to access Dalia's mailbox. 

Exporting to live Exchange is also available via the File menu.
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After establishing the connection, the export will start. Required time depends on how many items are selected
for export. You will be shown a progress window during the export. The window shows the number of saved
folders, messages, errors and total expected items to be restored. You can disable the progress window
directly in the window or go to the Options menu and select Show progress dialog. 
The export can be cancelled by clicking the Cancel exporting button on the taskbar. 
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5.3.2 Restore to live Exchange Server. Expert mode
Axcient DirectRestore includes the injection capability for items (emails, calendars, contacts, etc.) from offline
database and PST and OST files to live Exchange database.
The following options are presented:

· Authentication

· Connection to a mailbox using its owner credentials. To provide the connection, host (domain name or
IP), user logon name and password are required. It is also possible to connect through current Windows
credentials.

· Connection to another account mailbox by using Exchange impersonation. (http://msdn.microsoft.com/en-
us/library/bb204095%28EXCHG.140%29.aspx).

· Connecting to several mailboxes on different servers simultaneously.

· Browsing folder hierarchy of a connected mailbox, browsing folder contents and viewing message bodies
and other items (calendars, contacts).

· Creating folders in the connected mailbox.

· Drag-and-drop copying of folders and individual items from offline (source, EDB) database, PST or OST file
to the attached mailbox (destination live Exchange server).

· To provide injection, running the application as administrator or using a machine from AD domain, in which
there is Exchange Server with destination mailbox, is not required.

· Injection is possible to a local machine, as well as machines with Exchange Server, which are in the local
network or the Internet.

http://msdn.microsoft.com/en-us/library/bb204095%28EXCHG.140%29.aspx
http://msdn.microsoft.com/en-us/library/bb204095%28EXCHG.140%29.aspx
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Connection to Exchange Server
After opening a mail store the main window of the application looks as follows: 

There is a panel with a wide splitter added on the right. Toolbar buttons are added to connect to Exchange
Server and inject checked items to the attached mailbox.
The injection button (next to the Export selected data into PST button) becomes active when there is a
connection with at least one live mailbox and items in the offline database are checked.
The button for the connection to the mailbox has a drop-down list with mailboxes, which were attached
previously. When clicking Select menu item for the attached mailbox in the drop-down list, it appears in the
tree on the right and becomes selected. It is also possible to disconnect from the mailbox by clicking the
Disconnect menu item.

Clicking the connection toolbar button will bring up the following dialog for entering the credentials:
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Fill the following required fields:
• Host: domain name of the machine with Exchange Server, or IP address
• User logon name – user name to log on
• Password - user’s password
There is an option of connecting using current Windows credentials. When the checkbox is selected, the
User and Password fields are disabled:

It is possible to connect to someone else’s mailbox using Exchange impersonation. To do this, check the
Connect to a different mailbox box and enter the mailbox owner SMTP address:
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Connecting and exporting to live Exchange are also available through the File menu.
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Injection workflow
After the connection is established, the mail store tree appears on the Destination tab (1). It will be listed in
the drop-down list of the toolbar (2) connection button and in the File menu (3).

It is possible to select whether to show folder items and preview or not – a button near the Destination tab is
used for this purpose. If it is disabled there will be only a tree displayed in the right panel.

After enabling the button a list with the items is displayed as well as a preview when clicking on the item.
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Connection to several mailboxes simultaneously on different hosts is possible.

After mailbox appears in the tree, it is possible to drag-and-drop folders and separate items. When dragging a
folder or a mailbox to live Exchange mailbox, the hierarchy of the data being dragged will be recreated inside
the destination folder.
When right-clicking folders/mailboxes in the destination panel, it is possible to create a folder inside the
mailbox.
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It is also possible to delete and rename created folder within one program session. When checking the items
in the offline database, data exporting is available by clicking the Export into live Exchange Server mailbox
button. This method is the equivalent of saving to PST, except that the target is a live server, not a file. It is
complementary to drag-and-drop and useful for management of disparate data. With this method, items of
different types (e.g. notes and tasks) and/or located in different offline database folders/mailboxes or in
different PST/OST files can be exported.

When clicking the Export into live Exchange Server mailbox button, a dialog, which allows to select a folder
to save selected data, appears. Data hierarchy will be restored automatically. The root of hierarchy is the
closest common parent item.
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Create a new Exchange mailbox
Creating via main menu:

Creating using toolbar button:

Creating via context menu when live Exchange Server is connected (all fields in ‘Server Information’ window
will be filled in automatically based on connected mailbox info’):
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Mailbox creation window with server information filled in. ‘Host’ filed may contain either an IP addess of FQDN
of the server. User must have permission to create mailboxes.

Mailbox creation window with new user’s information filled in.
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Mailbox creation window with user’s alias and mailbox database fields. If mailbox database is not specified the
mailbox will be created in the default database.

Mailbox creation window with user’s alias and mailbox database specified. Refresh button is used to refresh
information about available databases in connected server.

Newly created mailbox is connected automatically if no errors were encountered during creaiton.
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Exchange Server settings for creating a new mailbox
As per Microsoft recommendation Hosting Controller will communicate with Exchange using Remote Power
Shell.
To start using HC with Exchange Server you would have to enable PS Remoting on Exchange CAS server
using following steps:
1.  Run  Enable-PSRemoting command in Exchange Management Shell.
2.  Enable BASIC authentication on Exchange PowerShell virtual directory in the IIS  Manager under 

Default Web Site.

3. Make sure that the user whose credentials you are using has “Remote PowerShell” enabled
a. get-user  USERNAME |fl RemotePowerShellEnabled 

Note: replace USERNAME with actual user name, e.g. ‘Administrator’
If the command above shows RemotePowerShellEnabled as False please execute the following command. 

b. set-user USERNAME -RemotePowerShellEnabled $True
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5.3.3 Working with clustered Exchange Server configuration
Exporting data into live instance of clustered Exchange Server does not differ from working with any other
server configuration. Even if there are several servers with Mailbox Server roles in your configuration, and
they have been added to your CCR/DAG, data can be easily restored. 

As you can see on the scheme, to export data into live server, Axcient DirectRestore calls Client Access
Server to get access to specified mailbox. And it doesn't really matter which of existing Mailbox Servers stores
target mailbox - data will be exported to the right place. 
The IP-address or FQDN of Client Access Server should be specified in the Host field while using the Expert
mode. In the Export into original mode FQDN of this server is detected automatically by calling Active
Directory domain controller. 
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5.3.4 Restore to PST files
To save items marked for export, click the Export selected items button on the toolbar or select the point in
the File menu.

You will be asked to select or create the destination folder for recovered data:

After selecting folder, the export will start. Required time depends on how many items are selected for export.
You will be shown a progress window during the export. The window shows the number of saved mailboxes,
folders, messages and total expected items to be restored (1). You can disable the progress window directly in
the window or go to the Options menu and select Show progress dialog.
The export can be cancelled by clicking an appropriate link in the progress dialog window (2) or by clicking
the Cancel export button on the taskbar (3).
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Tip
If you closed the progress window, it can be shown again by clicking on the progress bar on the status
panel.
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PST file naming, size and format
Axcient DirectRestore exports each mail store into a separate .pst file named “Recovery NNN - <Mailbox
Name>[ - VVV] . pst”, where NNN is current recovery session identifier, VVV – volume number in case the
PST has to be written in more than one volume.
Example:
Recovery 001 - John Doe.pst
Recovery 001 - John Doe - 001.pst
Recovery 001 - John Doe - 002.pst
Recovery 001 - Mary Smith.pst
With large exports, there can be more than one file on the output. Additional files are created automatically
when the file size limit is hit. The size volume limit depends on the output file encoding. For ANSI PST files the
limit is 1GB, for Unicode files it is 19GB.
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Opening exported items in Outlook
To view and manipulate exported items, use Microsoft Outlook to open the Personal Storage File (.pst) files
exported by Axcient DirectRestore:

1. Start Outlook.
2. Click File and choose Open Outlook Data File.
3. Select exported pst file and click OK.

Note
It is not recommended to move .pst files that are open in Outlook. Before moving, right-click the name of
the Outlook Data File (.pst) and click Close.
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Restoring exported items into Exchange Server
Items extracted from a mail store can be easily restored into a live server:
1. Make sure you have Microsoft Outlook with access to the mailbox you want to restore items into.
2. Open .pst file with exported messages.
3. Open the mailbox you need to import data into.
4. Select the items and drag-and-drop them back into the original folders. They will be automatically

synchronized with the live Exchange Server database.
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6 Command-line interface
The command line feature allows you to easily process several databases.
Usage: esr.exe <source> <destination>
Example: esr.exe "c:\Mailbox Database.edb" "c:\results\"
Below is a list of commands with their description that can be used in command line:

· There are several ways to set the source file(s):

Operation Description Example

<file mask path> mask to path with files esr.exe c:\*.edb c :\results\

/list=<path>
sets a path to a file that contains a
list of files to recover

esr.exe /list=d:\files_to_recover.txt
c:\results\

/list={file1, file2, …, fileN}
sets enumeration of files to
recover. Full path to file must be
used

esr.exe /list={d:\1.edb, d:\2.edb} c:
\results\

· Specify the destination directory for the recovered file(s):

Operation Description Example

<out dir> path to output directory esr.exe c:\*.edb c :\results\

· Detailing parameters:

Operation Description Example

/initdir=<path>
sets the initial directory for the
Open database dialog

esr.exe /initdir="c:\EDB Mailboxes\"

-notfilterfaultymessages shows messages that have been
filtered due to their damage

esr.exe -notfilterfaultymessages 

/redirect=<path> redirects console output to text file
esr.exe c:\*.edb c :
\results\ /redirect="c:\result.txt"

/cleartemp if set - the product will remove all
temp data on startup

esr.exe /cleartemp
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7 Glossary
This glossary lists terms and their synonyms, most commonly used in Axcient DirectRestore help.
AD - Active Directory (AD) is a directory service implemented by Microsoft for Windows domain networks. An
AD domain controller authenticates and authorizes all users and computers in a Windows domain type
network.
ANSI PST format - An old PST-file format, used in Outlook 97-2002. ANSI format has a 2 GB limit in file
size. 
Deleted items - Items/folders deleted from a mailbox hierarchy.
Destination folder/mailbox - A folder/mailbox, selected for export.
EDB - An Exchange database format, used to store information from users’ mailboxes. Synonyms: Exchange
Server database, dataset.
EWS - Exchange Web Services. EWS provides the functionality to enable client applications to communicate
with the Exchange server. EWS provides access to much of the same data that is made available through
Microsoft Office Outlook.
Exchange impersonation - Exchange impersonation enables a caller to impersonate a given account so that
the operations can be performed with the rights of the impersonated account, instead of the rights that are
associated with the caller's account. Configuration information is available at http://msdn.microsoft.com/en-
us/library/office/bb204095(v=exchg.140).aspx
Exchange Server - A mail server, calendaring software and contact manager developed by Microsoft.
Export - Copying information from an offline mailbox so it can be stored in a pst file or on the live Exchange
Server.
GMT - Greenwich Mean Time (GMT) is considered as a reference point for time.
Host - Domain name of the machine with Client Access role of Exchange Server, or IP address.
Injection - The process of copying data from offline mailbox to live or original connected mailbox on the
server.
Local time - Local time is calculated by adding or subtracting a number of hours, depending on a time zone,
to UTC.
Live Exchange Server mailbox - Destination Exchange server mailbox, that exists on the server and is
available for connection. Synonym: attached mailbox.
Mail Store - A type of self-storage whereby customers send items by mail or delivery service (usually by the
box) to be stored at a central location. Synonyms: mailbox, offline database, Outlook storage, database
storage (depending on the context). 
Original mailbox - A mailbox in live Exchange Server that corresponds to the mailbox in the opened database.
OST - An Offline Storage Table (.ost) format. OST is used by Microsoft Exchange Server that enables users
to work with their messages and mail data even when access to the mail server isn't available.
PST - A Personal Storage File (.pst) format, used to store copies of messages, calendar events, and other
items. PST files are readable with Outlook or other compatible email client.
Unicode PST format - A PST-file format used in Outlook 2003, Outlook 2007, Outlook 2010, Outlook 2013,
Outlook 2016 and Outlook 2019, so older versions of Outlook will not be able to open Unicode formatted PST
files. Previous versions of Outlook were using ANSI format. The main reason for this change was to allow for
international character support and to extend the maximum size of PST files beyond the 2GB limit of the ANSI
formatted PST files.
UTC - Coordinated Universal Time (UTC) is the primary time standard by which the world regulates clocks
and time. Usually used with references to time zones.
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